Boost C++ Libraries

...one of the most highly regarded and expertly designed C++ library projects in the world. Herb Sutter and Andrei Alexandrescu, C++ Coding Standards

Click here to view the latest version of this page.

Getting Started on Windows

A note to Cygwin and MinGW users

If you plan to use your tools from the Windows command prompt, you're in the right place. If you plan to build from the Cygwin bash shell, you're actually running on a POSIX platform and should follow the instructions for getting started on Unix variants. Other command shells, such as MinGW's MSYS, are not supported—they may or may not work.

Index

1   Get Boost

The easiest way to get a copy of Boost is to use the installer provided by Boost Consulting. We especially recommend this method if you use Microsoft Visual Studio .NET 2003 or Microsoft Visual Studio 2005, because the installer can download and install precompiled library binaries, saving you the trouble of building them yourself. To complete this tutorial, you'll need to at least install the Boost.Regex binaries when given the option.

If you're using an earlier version of Visual Studio or some other compiler, or if you prefer to build everything yourself, you can download boost_1_35_0.exe and run it to install a complete Boost distribution.1

2   The Boost Distribution

This is a sketch of the resulting directory structure:

boost_1_35_0\ .................The “boost root directory”
   index.htm .........A copy of www.boost.org starts here
   boost\ .........................All Boost Header files
   lib\ .....................precompiled library binaries
   libs\ ............Tests, .cpps, docs, etc., by library
     index.html ........Library documentation starts here
     algorithm\
     any\
     array\
                     …more libraries…
   status\ .........................Boost-wide test suite
   tools\ ...........Utilities, e.g. bjam, quickbook, bcp
   more\ ..........................Policy documents, etc.
   doc\ ...............A subset of all Boost library docs

It's important to note the following:

  1. The path to the boost root directory (often C:\Program Files\boost\boost_1_35_0) is sometimes referred to as $BOOST_ROOT in documentation and mailing lists .

  2. To compile anything in Boost, you need a directory containing the boost\ subdirectory in your #include path. Specific steps for setting up #include paths in Microsoft Visual Studio follow later in this document; if you use another IDE, please consult your product's documentation for instructions.

  3. Since all of Boost's header files have the .hpp extension, and live in the boost\ subdirectory of the boost root, your Boost #include directives will look like:

    #include <boost/whatever.hpp>
    

    or

    #include "boost/whatever.hpp"
    

    depending on your preference regarding the use of angle bracket includes. Even Windows users can (and, for portability reasons, probably should) use forward slashes in #include directives; your compiler doesn't care.

  4. Don't be distracted by the doc\ subdirectory; it only contains a subset of the Boost documentation. Start with libs\index.html if you're looking for the whole enchilada.

3   Header-Only Libraries

The first thing many people want to know is, “how do I build Boost?” The good news is that often, there's nothing to build.

Nothing to Build?

Most Boost libraries are header-only: they consist entirely of header files containing templates and inline functions, and require no separately-compiled library binaries or special treatment when linking.

The only Boost libraries that must be built separately are:

A few libraries have optional separately-compiled binaries:

4   Build a Simple Program Using Boost

To keep things simple, let's start by using a header-only library. The following program reads a sequence of integers from standard input, uses Boost.Lambda to multiply each number by three, and writes them to standard output:

#include <boost/lambda/lambda.hpp>
#include <iostream>
#include <iterator>
#include <algorithm>

int main()
{
    using namespace boost::lambda;
    typedef std::istream_iterator<int> in;

    std::for_each(
        in(std::cin), in(), std::cout << (_1 * 3) << " " );
}

Copy the text of this program into a file called example.cpp.

Note

To build the examples in this guide, you can use an Integrated Development Environment (IDE) like Visual Studio, or you can issue commands from the command prompt. Since every IDE and compiler has different options and Microsoft's are by far the dominant compilers on Windows, we only give specific directions here for Visual Studio 2005 and .NET 2003 IDEs and their respective command prompt compilers (using the command prompt is a bit simpler). If you are using another compiler or IDE, it should be relatively easy to adapt these instructions to your environment.

4.1   Build From the Visual Studio IDE

  • From Visual Studio's File menu, select New > Project…

  • In the left-hand pane of the resulting New Project dialog, select Visual C++ > Win32.

  • In the right-hand pane, select Win32 Console Application (VS8.0) or Win32 Console Project (VS7.1).

  • In the name field, enter “example”

  • Right-click example in the Solution Explorer pane and select Properties from the resulting pop-up menu

  • In Configuration Properties > C/C++ > General > Additional Include Directories, enter the path to the Boost root directory, for example

    C:\Program Files\boost\boost_1_35_0

  • In Configuration Properties > C/C++ > Precompiled Headers, change Use Precompiled Header (/Yu) to Not Using Precompiled Headers.3

  • Replace the contents of the example.cpp generated by the IDE with the example code above.

  • From the Build menu, select Build Solution.

To test your application, hit the F5 key and type the following into the resulting window, followed by the Return key:

1 2 3

Then hold down the control key and press "Z", followed by the Return key.

skip to the next step

4.2   Or, Build From the Command Prompt

From your computer's Start menu, if you are a Visual Studio 2005 user, select

All Programs > Microsoft Visual Studio 2005 > Visual Studio Tools > Visual Studio 2005 Command Prompt

or, if you're a Visual Studio .NET 2003 user, select

All Programs > Microsoft Visual Studio .NET 2003 > Visual Studio .NET Tools > Visual Studio .NET 2003 Command Prompt

to bring up a special command prompt window set up for the Visual Studio compiler. In that window, set the current directory to a suitable location for creating some temporary files and type the following command followed by the Return key:

cl /EHsc /I path\to\boost_1_35_0 path\to\example.cpp

To test the result, type:

echo 1 2 3 | example

4.3   Errors and Warnings

Don't be alarmed if you see compiler warnings originating in Boost headers. We try to eliminate them, but doing so isn't always practical.5 Errors are another matter. If you're seeing compilation errors at this point in the tutorial, check to be sure you've copied the example program correctly and that you've correctly identified the Boost root directory.

5   Prepare to Use a Boost Library Binary

If you want to use any of the separately-compiled Boost libraries, you'll need to acquire library binaries.

5.1   Install Visual Studio (2005 or .NET 2003) Binaries

The installer supplied by Boost Consulting will download and install pre-compiled binaries into the lib\ subdirectory of the boost root, typically C:\Program Files\boost\boost_1_35_0\lib\. If you installed all variants of the Boost.Regex binary, you're done with this step. Otherwise, please run the installer again and install them now.

skip to the next step

5.2   Or, Build Binaries From Source

If you're using an earlier version of Visual C++, or a compiler from another vendor, you'll need to use Boost.Build to create your own binaries.

Boost.Build is a text-based system for developing, testing, and installing software. To use it, you'll need an executable called bjam.

5.2.1   Get bjam

bjam is the command-line tool that drives the Boost Build system. To build Boost binaries, you'll invoke bjam from the Boost root.

Boost provides pre-compiled bjam executables for a variety of platforms. Alternatively, you can build bjam yourself using these instructions.

5.2.2   Identify Your Toolset

First, find the toolset corresponding to your compiler in the following table.

Note

If you previously chose a toolset for the purposes of building bjam, you should assume it won't work and instead choose newly from the table below.

Toolset Name Vendor Notes
acc Hewlett Packard Only very recent versions are known to work well with Boost
borland Borland  
como Comeau Computing Using this toolset may require configuring another toolset to act as its backend
cw Metrowerks/FreeScale The CodeWarrior compiler. We have not tested versions of this compiler produced since it was sold to FreeScale.
dmc Digital Mars As of this Boost release, no version of dmc is known to handle Boost well.
darwin Apple Computer Apple's version of the GCC toolchain with support for Darwin and MacOS X features such as frameworks.
gcc The Gnu Project Includes support for Cygwin and MinGW compilers.
hp_cxx Hewlett Packard Targeted at the Tru64 operating system.
intel Intel  
kylix Borland  
msvc Microsoft  
qcc QNX Software Systems  
sun Sun Only very recent versions are known to work well with Boost.
vacpp IBM The VisualAge C++ compiler.

If you have multiple versions of a particular compiler installed, you can append the version number to the toolset name, preceded by a hyphen, e.g. intel-9.0 or borland-5.4.3. On Windows, append a version number even if you only have one version installed (unless you are using the msvc or gcc toolsets, which have special version detection code) or auto-linking will fail.

5.2.3   Select a Build Directory

Boost.Build will place all intermediate files it generates while building into the build directory. If your Boost root directory is writable, this step isn't strictly necessary: by default Boost.Build will create a bin.v2/ subdirectory for that purpose in your current working directory.

5.2.4   Invoke bjam

Change your current directory to the Boost root directory and invoke bjam as follows:

bjam --build-dir=build-directory --toolset=toolset-name stage

For example, your session might look like this:4

C:\WINDOWS> cd C:\Program Files\boost\boost_1_35_0
C:\Program Files\boost\boost_1_35_0> bjam ^
More? --build-dir="C:\Documents and Settings\dave\build-boost" ^
More? --toolset=msvc stage

Be sure to read this note about the appearance of ^, More? and quotation marks (") in that line.

Building the special stage target places Boost library binaries in the stage\ subdirectory of your build directory.

Note

bjam is case-sensitive; it is important that all the parts shown in bold type above be entirely lower-case.

For a description of other options you can pass when invoking bjam, type:

bjam --help

In particular, to limit the amount of time spent building, you may be interested in:

  • reviewing the list of library names with --show-libraries
  • limiting which libraries get built with the --with-library-name or --without-library-name options
  • choosing a specific build variant by adding release or debug to the command line.

5.3   Expected Build Output

During the process of building Boost libraries, you can expect to see some messages printed on the console. These may include

  • Notices about Boost library configuration—for example, the Regex library outputs a message about ICU when built without Unicode support, and the Python library may be skipped without error (but with a notice) if you don't have Python installed.

  • Messages from the build tool that report the number of targets that were built or skipped. Don't be surprised if those numbers don't make any sense to you; there are many targets per library.

  • Build action messages describing what the tool is doing, which look something like:

    toolset-name.c++ long/path/to/file/being/built
    
  • Compiler warnings.

5.4   In Case of Build Errors

The only error messages you see when building Boost—if any—should be related to the IOStreams library's support of zip and bzip2 formats as described here. Install the relevant development packages for libz and libbz2 if you need those features. Other errors when building Boost libraries are cause for concern.

If it seems like the build system can't find your compiler and/or linker, consider setting up a user-config.jam file as described in the Boost.Build documentation. If that isn't your problem or the user-config.jam file doesn't work for you, please address questions about configuring Boost for your compiler to the Boost.Build mailing list.

7   Conclusion and Further Resources

This concludes your introduction to Boost and to integrating it with your programs. As you start using Boost in earnest, there are surely a few additional points you'll wish we had covered. One day we may have a “Book 2 in the Getting Started series” that addresses them. Until then, we suggest you pursue the following resources. If you can't find what you need, or there's anything we can do to make this document clearer, please post it to the Boost Users' mailing list.

Onward

Good luck, and have fun!

—the Boost Developers


[1]If you prefer not to download executable programs, download boost_1_35_0.zip and use an external tool to decompress it. We don't recommend using Windows' built-in decompression as it can be painfully slow for large archives.
[2]If you used the installer from Boost Consulting and deselected “Source and Documentation” (it's selected by default), you won't see the libs/ subdirectory. That won't affect your ability to use precompiled binaries, but you won't be able to rebuild libraries from scratch.
[3]There's no problem using Boost with precompiled headers; these instructions merely avoid precompiled headers because it would require Visual Studio-specific changes to the source code used in the examples.
[4]

In this example, the caret character ^ is a way of continuing the command on multiple lines, and must be the final character used on the line to be continued (i.e. do not follow it with spaces). The command prompt responds with More? to prompt for more input. Feel free to omit the carets and subsequent newlines; we used them so the example would fit on a page of reasonable width.

The command prompt treats each bit of whitespace in the command as an argument separator. That means quotation marks (") are required to keep text together whenever a single command-line argument contains spaces, as in

--build-dir="C:\Documents_and_Settings\dave\build-boost"

Also, for example, you can't add spaces around the = sign as in

--build-dir_=_"C:\Documents and Settings\dave\build-boost"
[5]Remember that warnings are specific to each compiler implementation. The developer of a given Boost library might not have access to your compiler. Also, some warnings are extremely difficult to eliminate in generic code, to the point where it's not worth the trouble. Finally, some compilers don't have any source code mechanism for suppressing warnings.
[6]This convention distinguishes the static version of a Boost library from the import library for an identically-configured Boost DLL, which would otherwise have the same name.
[7]These libraries were compiled without optimization or inlining, with full debug symbols enabled, and without NDEBUG #defined. Although it's true that sometimes these choices don't affect binary compatibility with other compiled code, you can't count on that with Boost libraries.
[8]This feature of STLPort is deprecated because it's impossible to make it work transparently to the user; we don't recommend it.